Scanii.com web portal not available
Incident Report for Scanii.com
Resolved
This incident has been resolved.
Posted Jun 21, 2020 - 10:19 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 21, 2020 - 09:47 EDT
This incident affected: Management Portal (scanii.com).